Contribution manager not loading libraries

Incident Report for Processing Foundation

Resolved

The migration of download.processing.org/contribs to Netlify seemingly solved the issue with the contribution manager. Monitoring showed no further incidents.
Posted Dec 23, 2024 - 14:16 UTC

Investigating

To ensure the Contribution Manager remains operational, we’ve migrated download.processing.org/contribs to Netlify. It should now function as usual.

The legacy server kept crashing so we took it offline for future investigation. Legacy sites, including forum.processing.org (old forums archive), /stats/, and /bugzilla/, are therefore offline. We’ll address these after investigating the server issues.

Thank you for your patience during the holiday break. For now, the Internet Archive can be used to access the old forums archive: https://web.archive.org/web/20240913031547/http://forum.processing.org/

The current forums are not affected and can be accessed as usual at https://discourse.processing.org/
Posted Dec 22, 2024 - 12:12 UTC

Monitoring

The issue was mitigated with a reboot, and the server is now operational.
Posted Dec 21, 2024 - 18:24 UTC

Investigating

We are currently investigating this issue.
Posted Dec 21, 2024 - 17:57 UTC
This incident affected: Processing Contribution Manager.